PCAN Fails to Acknowledge Messages

This forum covers issues concerning multiple hardware products.
Post Reply
AutoMotivePower
Posts: 1
Joined: Tue 21. May 2019, 00:59

PCAN Fails to Acknowledge Messages

Post by AutoMotivePower » Tue 21. May 2019, 01:26

Hi,

We are running into a problem where the PCAN dongle is failing to acknowledge messages coming from our board. This only happens when we are doing a high bus load transfer for a bootloader application (500Kbaud rate). Our self written client application running on our PC expects a flow control message instead an error frame is logged. On the scope we can see that the flow control frame actually did get sent out from our bootloader but the pcan does not ack the message (See attached image). Error does not go away when going to 250K baud. Error does not away when slowing down the download rate.

We are using the IPEH-002021 dongle with PCAN ISO-TP dll on a windows machine.
Attachments
234BadAck.PNG
234BadAck.PNG (546.34 KiB) Viewed 10347 times

User avatar
U.Wilhelm
Sales & Support
Sales & Support
Posts: 1190
Joined: Fri 10. Sep 2010, 19:34

Re: PCAN Fails to Acknowledge Messages

Post by U.Wilhelm » Tue 21. May 2019, 08:14

Nice Picture - but what would you like to show us..without more info it is a simple Bitmap...
Before you go to deep in Bits, check with running PCAN-View with the 100% correct timings and a terminated CAN cable the communication. Forget ISO TP it´s a SW protocoll - run first CAN-Layer2.

Set the Tracer Options in PCAN-View to also LOG Errors, send and receive some Frames and send us the LOG File, or check by yourself. But please keep in mind - the Adpater is sold nearly 1Mio. times - this unit works if you did not destroy it (ever check Transceiver voltages?) So maybe, you check your hardware / application again.
--------------------------------
PEAK-System Technik
Technical Support Team
support@peak-system.com
-------------------------------

Post Reply