No node connected PCAN-USB vs PCAN-USB FD

This forum covers issues concerning multiple hardware products.
Post Reply
Pawel_G
Posts: 2
Joined: Tue 16. Feb 2021, 11:10

No node connected PCAN-USB vs PCAN-USB FD

Post by Pawel_G » Tue 16. Feb 2021, 12:02

Hi!

In my team we are performing some CAN tests using PCAN-USB and PCAN-USB FD. We have faced some differences in handling no connection to any other node. Attempting to send frame via PCAN-USB (white one) makes it become Bus Passive State
pcan-usb1.png
pcan-usb1.png (112.46 KiB) Viewed 1580 times
While PCAN-USB FD (black one) remains active:
pcan-usb2.png
pcan-usb2.png (126.57 KiB) Viewed 1580 times
We are wondering what is the reason of such difference and which approach of handling this scenario is the most common?

Best regards, Paweł Gmurczyk

M.Heidemann
Sales & Support
Sales & Support
Posts: 673
Joined: Fri 20. Sep 2019, 13:31

Re: No node connected PCAN-USB vs PCAN-USB FD

Post by M.Heidemann » Tue 16. Feb 2021, 13:08

Hello,

On a CAN-Bus there always need to be at least 2 nodes present, otherwise the messages sent cannot be acknowledged and will lead to error states.
The PCAN-USB FD does need a termination to operate correctly, most likely you have also removed the termination hence why the node stays active.
The hardware on PCAN-USB and PCAN-USB FD is different, where the PCAN-USB is a SJA-1000 hardware, the PCAN-USB FD used an FPGA. Furthermore do both devices use different Transceivers.

And what do you mean by "handling such a scenario"? Ideally, at least 2 nodes are on the bus, the error will always show up
if no other nodes are present when sending CAN-Frames.
If it is present on a bus with other nodes active it most likely is a physical issue:

-> Other nodes are in listenonly-mode (Do not acknoweldge frames, transmitting noce gets no acknowledgment)
-> Missing termination
-> Wrong bitrate
-> broken cables, etc.

For further information feel free to contact us again.

Best Regards

Marvin

Post Reply