Firmware Update for PCAN-DIAG V2 to 1.7.1

Handheld CAN Bus Diagnostics Unit - Version 2
Post Reply
User avatar
U.Wilhelm
Sales & Support
Sales & Support
Posts: 1317
Joined: Fri 10. Sep 2010, 19:34

Firmware Update for PCAN-DIAG V2 to 1.7.1

Post by U.Wilhelm » Fri 25. May 2012, 09:35

The Firmware Update for the PCAN-Diag 2 to 1.7.1 is now available. Firmware Update Information

Only V2 units with USB connector are supported - do NOT try to flash the Firmware on a V1 Diag Device!

To use this Firmware on your PCAN-Diag2 Device please check if your Seriealnumber is greater than #150.

HowTo:
- you need to download the Firmware 1.7.1 here
- connect your PCAN-DIAG2 via USB to your PC
- Delete all Data on the Device except your own Projects in the Projects directory
- copy the complete Data from the Firmware (unzip) to the Device (incl. the PCAN-Diag directory)
- Disconnect the Device from the USB cable
- Switch on the Device and goto „Internal Statistics“
- Select "Update Firmware" – use Firmware 1.7.1 file and start update

Now the new Firmware, the new Symbol Editor, the Trace Converter (for using the Trace Files with PCAN-Explorer or any other PC Software) and the new PCAN-Diag2 Configuration Tool, incl. Online Help is available on your Device. Since Devices with SerNo 294, we use fast SLC Memory cards inside the Device. This units are able to trace CAN data with 1MB and 100% busload without any problems. Older Devices have non SLC cards, with less performance. But in most cases it is enought to Trace your CAN Data (see Buffer status while trace CAN Data)

We also offer to Update to SLC Memory, if you have problems with the writing performance of your Device. For that we need to open the housing, so the device must be shipped to our workshop in Darmstadt/Germany. The cost is depending on the size (1 or 2Gbyte) and shipping.
For more information, please contact support@peak-system.com

! ATTENTION !
If your System have a Version 1.5.1, you need to set the Date to a month with a single number (01 to 09) - due to a bug in the firmware, the unit could only be update between January and September :ugeek: - sounds strange but it's a BUG in the V1.5.1 - sorry!
Last edited by U.Wilhelm on Thu 31. May 2012, 21:39, edited 1 time in total.
--------------------------------
PEAK-System Technik
Technical Support Team
support@peak-system.com
-------------------------------

Post Reply