Lin to RS-232 autoreply

RS-232 to CAN/LIN Interface
Post Reply
kwoodbrandelle
Posts: 1
Joined: Tue 28. Jan 2014, 16:20

Lin to RS-232 autoreply

Post by kwoodbrandelle » Tue 28. Jan 2014, 16:31

Hi, I'm new to this module, I have been able to send and receive commands on request. The problem I am having is we need to issue a command and wait for the automatic reply. Could someone point me in the right direction.

0x02 0x09 0x81 0x3c 0x09 0x89 0x09 0xf0 0x01 0xd1 0x04 0xff 0xe6

Above is the format of the command.
The current configuration file is attached.

Thanks
Attachments
PCAN LIN Jan 28 14.pclin
(35.72 KiB) Downloaded 681 times

M.Maidhof
Support
Support
Posts: 1303
Joined: Wed 22. Sep 2010, 14:00

Re: Lin to RS-232 autoreply

Post by M.Maidhof » Wed 29. Jan 2014, 10:15

Hi,

when you do a master-request/slave-responds communication (0x3C/0x3D) as a LIN master, you must also send the subscriber frame for 0x3D, to get the answer from your LIN slave.

0x02 0x01 0x81 0xBD 0x3D

regards

Michael

ssm_lin
Posts: 1
Joined: Thu 12. Mar 2020, 07:36

Re: Lin to RS-232 autoreply

Post by ssm_lin » Thu 12. Mar 2020, 08:10

Gentleman,

I have the same problem as the original poster. I have PCAN-LIN module as the master, which is used to communicate and control the speed of the cooling fan. My operation is as below:
* Step 1: sending my frame 02 09 81 3C FA 02 10 60 00 00 00 00 3C, which is in order to start the diagnostic session;
* Step 2: Then the program got the reply of 02 01 00 01, which means the sending frame is OK without error;
* Step 3: Then I sent the 02 01 81 BD 3D frame in order to get the ID 3D frame which should be the response from the slave node;
* Step 4: The PCAN-LIN module's RS232 interface only reply me with the frame 02 01 00 01, but not the response frame with 3D that I want.

Another phenomenon is that the "Transmission active" LED turned on red after the step 3 action. I have also attached my .pclin file.

Thanks for your support in advance & looking forward to your reply!

Lin Zhang
Attachments
GatewayLinRs232b.pclin
(43.1 KiB) Downloaded 54 times

M.Maidhof
Support
Support
Posts: 1303
Joined: Wed 22. Sep 2010, 14:00

Re: Lin to RS-232 autoreply

Post by M.Maidhof » Thu 12. Mar 2020, 09:42

Hi,

please set the error RS-232 Error in the forward mask for LIN, so that you will see an error (slave not responding) when the 3D subscriber will not be answered by your LIN node.

Are you sure you will get a response on 3D for a change of diagnostic session? Please try to send a tester present, to get a response.

best regards

Michael

Post Reply