Can not control LIN slave devices from CAN messages

RS-232 to CAN/LIN Interface
Post Reply
AbelOverride
Posts: 5
Joined: Wed 18. Sep 2019, 14:57

Can not control LIN slave devices from CAN messages

Post by AbelOverride » Wed 18. Sep 2019, 15:19

Hello,

I'm trying to manage two LIN latches with two CAN messages.

The feedback messages are ok but when I'm trying to control the latches, the latches don't follow the commands...

I think I have the correct schedule time and publisher and subscriber ID's.

Thanks for your help.
Attachments
CAN_LIN_gateway_feedback_working_v002.pclin
(43.57 KiB) Downloaded 104 times

M.Maidhof
Support
Support
Posts: 1307
Joined: Wed 22. Sep 2010, 14:00

Re: Can not control LIN slave devices from CAN messages

Post by M.Maidhof » Wed 18. Sep 2019, 15:54

Hi,

what kind of CAN messages did you send to the PCAN-LIN? Please note that you have to use an offset of 0x40 for the CAN ID to change the publisher data. In your case you have to send a CAN ID 0x04 +0x40 +CAN-ID Offset (in your case 0x48E) = 0x4D2 with dlc 2 to change the publisher data of LIN ID 0x04.

regards

Michael

AbelOverride
Posts: 5
Joined: Wed 18. Sep 2019, 14:57

Re: Can not control LIN slave devices from CAN messages

Post by AbelOverride » Wed 18. Sep 2019, 17:00

Hi Michael,

Yes, I did it and that's not the problem. I think the problem is with the timing or the counter... With direct LIN messages, my configuration is working fine but when I add the PCAN-LIN... The latches are not following my commands...

The frame configuration is OK and the scheduler also.It Is following the .ldf table...
Image

Image

Any other idea?

Thanks a lot!
Abel.

M.Maidhof
Support
Support
Posts: 1307
Joined: Wed 22. Sep 2010, 14:00

Re: Can not control LIN slave devices from CAN messages

Post by M.Maidhof » Thu 19. Sep 2019, 09:16

Hi,

do you have a ldf of your LIN system, to see the length code and checksum type of the used LIN frames?

regards

Michael

AbelOverride
Posts: 5
Joined: Wed 18. Sep 2019, 14:57

Re: Can not control LIN slave devices from CAN messages

Post by AbelOverride » Thu 19. Sep 2019, 11:01

Hi Michael,

Yes! Take a look:

Image

What do you think? I'm going to record a log with PLIN.

Thanks,
Abel.

M.Maidhof
Support
Support
Posts: 1307
Joined: Wed 22. Sep 2010, 14:00

Re: Can not control LIN slave devices from CAN messages

Post by M.Maidhof » Thu 19. Sep 2019, 15:54

unfortunately I can't see any baudrate settings in your screenshot. Please be sure that you disable the publisher from your other LIN device, while using PCAN-LIN. It is not possible that there are two devices setting the same publisher data.

regards

Michael

AbelOverride
Posts: 5
Joined: Wed 18. Sep 2019, 14:57

Re: Can not control LIN slave devices from CAN messages

Post by AbelOverride » Thu 19. Sep 2019, 16:31

Hi Michael,

Image

Baudrate is 19.200 Kbps.
I only have one Master device (PCAN-LIN) and two slave devices. Please, take a look to the log with PLIN-USB.
I do not know why PCAN-LIN is not working...

Thanks again!
Abel.
Attachments
PLIN_log_VECTOR_PCAN_LIN_not_working_ok.ltrc
(200.09 KiB) Downloaded 97 times

M.Maidhof
Support
Support
Posts: 1307
Joined: Wed 22. Sep 2010, 14:00

Re: Can not control LIN slave devices from CAN messages

Post by M.Maidhof » Thu 19. Sep 2019, 17:18

Hi,

do you have a ldf of that system, to see which frames are publisher and which are subscriber. This is not clear for me from your screenshots.

regards

Michael

AbelOverride
Posts: 5
Joined: Wed 18. Sep 2019, 14:57

Re: Can not control LIN slave devices from CAN messages

Post by AbelOverride » Fri 20. Sep 2019, 08:14

Hi Michael,

Please find attached the ldf file.

Thank you!
Abel.
Attachments
PCL_2door_SecurityLIN_Rel5_2_CONV_FULL.ldf
(7.43 KiB) Downloaded 101 times

M.Maidhof
Support
Support
Posts: 1307
Joined: Wed 22. Sep 2010, 14:00

Re: Can not control LIN slave devices from CAN messages

Post by M.Maidhof » Mon 23. Sep 2019, 11:30

Hi,

your configuration looks ok. Can you please contact me by phone or email (use our support email address) to check your setup again. Thank you.

regards

Michael

Post Reply