Slave node cannot receive the frame

This is a forum for the communication between the beta testers and our developers. It is only visible for PEAK-System employees and authorized testers.
aguan.zhang
Posts: 17
Joined: Thu 18. Jun 2020, 05:11

Re: Slave node cannot receive the frame

Post by aguan.zhang » Thu 2. Jul 2020, 09:49

Hi Marvin,

the PCAN-USB Pro FD works well on Windows using PLIN-View Pro and
the PLIN-Driver works well on Ubuntu 16.04. Thanks very much for your supporting .

I have a new question.

I connect the PIN 4 to a real LIN device which can show PM25, and I update the LIN Frame data 0x38
in the slave mode using PLIN-View Pro, the PM25 can changing with setting value. please refer to the attachment.

But when i using the PLIN-Driver, my LIN device cannot receive my setting value when executing whether in slave node or master node:

Code: Select all

lin start master 19200 /dev/plin1
linwrite -i=0x38 -b="ff 0 0 0 0 0 0 0" -c=E -d=P /dev/plin1
or

Code: Select all

lin start slave 19200 /dev/plin1
linwrite -i=0x38 -b="ff 0 0 0 0 0 0 0" -c=E -d=P /dev/plin1
Does the slave mode support publishing data in PLIN-Driver ?

Thanks in advance.
BRs
Aguan
Attachments
3.PNG
3.PNG (44.81 KiB) Viewed 420 times

M.Heidemann
Sales & Support
Sales & Support
Posts: 405
Joined: Fri 20. Sep 2019, 13:31

Re: Slave node cannot receive the frame

Post by M.Heidemann » Thu 2. Jul 2020, 11:13

Hello Aguan,

You have to create a frame entry, right now you are only sending the frame as is.
In order for your slave node to respond to subscriber frame it needs some information, here's how you do it:

1. (as a slave node) Set an entry for the publisher frame that will be sent out in response to the master subscriber frame:

Code: Select all

 lin set pub-frm-entry 0x38 --rsp-enable --cs-enhanced --len 8 /dev/plin0
Please make sure that you use

Code: Select all

--rsp-enable
when setting up frames, otherwise this frame will not be sent in response to subscriber frames.

Then you can chage the data of the frame like this:

Code: Select all

lin set frm-entry-data 0x038 --data "122 222 90 86 22 01 123 111" /dev/plin0
if you prefer to set the data as hex-values:

Code: Select all

 lin set frm-entry-data 0x38 --data "0x1A 0xBB 0x66 0xB2 0xFF 0xDD 0xFA 0xF3" /dev/plin0
Now your slave node will publish this frame in response to an subscriber frame with the appropiate data.

Please report back to me if this solved your issue.


Best Regards

Marvin

aguan.zhang
Posts: 17
Joined: Thu 18. Jun 2020, 05:11

Re: Slave node cannot receive the frame

Post by aguan.zhang » Fri 3. Jul 2020, 05:11

Hi Marvin,

Thanks for your support.

The slave node can publish the frame data with your methods.

BRs
Aguan

M.Heidemann
Sales & Support
Sales & Support
Posts: 405
Joined: Fri 20. Sep 2019, 13:31

Re: Slave node cannot receive the frame

Post by M.Heidemann » Fri 3. Jul 2020, 09:13

Hello Aguan,

You're welcome!

We appreciate your input, if you have any suggestions
regarding the documentation of certain aspects or functionality featured in the driver itself,
feel free to open up a thread in this forum.

Best Regards

Marvin

Locked