PCAN_UDS_ISOTP_API_ON_LINUX

This forum covers PCAN-Linux and Linux development issues concerning our products
Post Reply
Shail
Posts: 49
Joined: Tue 28. Apr 2020, 10:09

PCAN_UDS_ISOTP_API_ON_LINUX

Post by Shail » Thu 26. Jan 2023, 16:09

Hello,

We found only Windows level SW Devlopment API for PCAN on PEAK Website:
PCAN-UDS API, PCAN-Basic API, PCAN-ISO-TP API : API for the development of applications with CAN and CAN FD connections for Windows® 11 (x64/ARM64), 10 (x86/x64).
https://www.peak-system.com/PCAN-UDS-AP ... .html?&L=1

1) We are looking for PCAN-UDS API and PCAN-ISO-TP API for LINUX OS.
Do you provide the LINUX API for PEAK Devlopment?

2) Below mentioned driver only available for PCAN basic API. but what about PCAN-ISOTP and PCAN USB API?
https://www.peak-system.com/fileadmin/m ... /index.htm
If you are using Linux environments missing a driver (e.g. minimized Linux environments, older Kernels) or you want to use our character-based driver (chardev) e.g. in connection with the PCAN-Basic API, you need our PCAN Driver for Linux package and compile the driver yourself.

User avatar
U.Wilhelm
Sales & Support
Sales & Support
Posts: 1588
Joined: Fri 10. Sep 2010, 19:34

Re: PCAN_UDS_ISOTP_API_ON_LINUX

Post by U.Wilhelm » Thu 26. Jan 2023, 18:10

We do not offer our closed source High Layer APIs for Linux.
We have port the PCAN-Baisc API for Linux.
--------------------------------
PEAK-System Technik
Technical Support Team
support@peak-system.com
-------------------------------

Shail
Posts: 49
Joined: Tue 28. Apr 2020, 10:09

Re: PCAN_UDS_ISOTP_API_ON_LINUX

Post by Shail » Fri 27. Jan 2023, 06:06

Hello,

Thanks for your input.

1) Can u please provide the DLL and header for the development same like windows APIs?
We do not need source code for ISOTP and PCAN-UDS APIS

2) If we have more than 8 bytes of data then how we can send data? Or suggest alternate way of doing it?

Thanks

User avatar
U.Wilhelm
Sales & Support
Sales & Support
Posts: 1588
Joined: Fri 10. Sep 2010, 19:34

Re: PCAN_UDS_ISOTP_API_ON_LINUX

Post by U.Wilhelm » Fri 27. Jan 2023, 08:15

We do not offer for LINUX LIB Files (Linux do not use DLLs) for the High Layer APIs to customers. You need to use Windows, or build your own APIs.

Sending more then 8 Data Bytes on a CAN2.0a/b Network (fragmented Messages) is depending on which High Layer protocol you use.
It is not possible in the Layer 2 (Raw CAN) . So you need to implement this Transport Layer by your own or use a predefined Protocol.
If you use the Linux driver in Socket CAN (NetDev) mode there is a ISO-TP implementation available.
--------------------------------
PEAK-System Technik
Technical Support Team
support@peak-system.com
-------------------------------

Post Reply