Digital input various results

Universal I/O Module with CAN Interface
Locked
marek.belisko
Posts: 8
Joined: Fri 12. Jul 2019, 08:40

Digital input various results

Post by marek.belisko » Wed 27. Nov 2019, 12:14

Hi,

I'm using MicroMod Mix3 to capture state of digital inputs. I use DIN0 - DIN2 as inputs and while set on all of then reference 4.8V when capture received data by using candump I see n that I get logical 1 but after some seconds it goes to logical 0 and then back to logical 1. as said I have stable input voltage 4.8V. Any ideas what can cause this issue? I have basic setup only (no changes in DIP switches though). Thanks.

M.Heidemann
Sales & Support
Sales & Support
Posts: 686
Joined: Fri 20. Sep 2019, 13:31

Re: Digital input various results

Post by M.Heidemann » Wed 27. Nov 2019, 13:37

Hello,

Can you send us your configuration-file (.mcf) to support[at]peak-system.com?

Please reference this post in your email.

It's hard to evaluate whats the issue without seeing the configuration.

Best Regards

Marvin

marek.belisko
Posts: 8
Joined: Fri 12. Jul 2019, 08:40

Re: Digital input various results

Post by marek.belisko » Tue 3. Dec 2019, 08:56

Hi,

it looks like I need to provide input voltage higher then 4,7-4,8V otherwise detection is not reliable. Not I provide bit more and it works perfectly fine. Thanks.

BR,

marek

User avatar
U.Wilhelm
Sales & Support
Sales & Support
Posts: 1272
Joined: Fri 10. Sep 2010, 19:34

Re: Digital input various results

Post by U.Wilhelm » Thu 2. Jan 2020, 21:51

4.8V is the minimum Voltage for detecting the High Level. it is always better to add some milivolts on top for exact detecting the High Level.
Unbenannt.JPG
Unbenannt.JPG (13.54 KiB) Viewed 2039 times
--------------------------------
PEAK-System Technik
Technical Support Team
support@peak-system.com
-------------------------------

Locked