I can't establish a UDS session with a Digital Tachograph

A free API for the communication with control devices according to UDS (ISO 14229-1)
Post Reply
Arn100
Posts: 2
Joined: Sun 22. Dec 2019, 21:32

I can't establish a UDS session with a Digital Tachograph

Post by Arn100 » Sat 4. Jan 2020, 23:27

Hello everyone, I'm very tender and i started with the UDS protocol. The project that I have in mind, is to establish a session with a digital tachograph that canbus connects to the ECU master. The problem is that I'm repeatedly seeing the message "NO UDS RESPONSE" Although if I can read the canbus traffic perfectly.

(64-bit dlls are in right place, System32)
https://www.peak-system.com/forum/viewt ... t=SYSWOW64

(and after 2 months trying in different ways I can not see where I'm wrong)
the UDS messages I get are these:

*******************************************************************************************
02 10 02

Sends a Physical TesterPresent Message with no positive response :
UDS_SvcTesterPresent: 7

UDS request from 0xf1 (to 0x01, with RA 0x00) - result: 0 - OK !
\-> Length: 2, Data= 3e 80

Press <Enter> to continue...
********************************************************
02 3e 80

*** UDS Service: ReadMemoryByAddress ***


Sends a Physical ReadMemoryByAddress Message:
UDS_SvcReadMemoryByAddress: -2147483648

UDS request from 0xf1 (to 0x01, with RA 0x00) - result: 2 - ERROR !!!
\-> Length: 15, Data= 23 3a 41 42 43 44 45 46 47 48 49 4a 31 32 33
/!\ ERROR : NO UDS RESPONSE !!

Press <Enter> to continue...
****************************************************************************


Anyone have any ideas to get out of this strike?


thanks in advance

User avatar
U.Wilhelm
Sales & Support
Sales & Support
Posts: 1198
Joined: Fri 10. Sep 2010, 19:34

Re: I can't establish a UDS session with a Digital Tachograp

Post by U.Wilhelm » Mon 6. Jan 2020, 08:20

We only could provide the Tools, but not the final solution. Please contact the ECU/Tachograph manufacturer. Only they could answer for your question. Maybe they use differnet Keys/Checksumms or have any other protection...

To check if the CAN Frames itself will be send / receive try PCAN-View first, then use a PCAN-Basic API (CAN Layer 2 Sample).You also could try to detect the OBD-II communication on the CAR/Vehicle to see if the unit reply. A full working sample OBD-II scanner is part of our free Tools.
--------------------------------
PEAK-System Technik
Technical Support Team
support@peak-system.com
-------------------------------

Arn100
Posts: 2
Joined: Sun 22. Dec 2019, 21:32

Re: I can't establish a UDS session with a Digital Tachograp

Post by Arn100 » Mon 6. Jan 2020, 22:52

Thanks a lot.

To rule out I tried with my car and I have the same problem, I can't establish a UDS session.

The question I have is if I need to connect to the ground of pin 3 and 6 of the DB9 connection, since only by connecting pin 2 of (CAN-L) and 7 of (CAN-H), I can already visualize the canbus traffic.

Are ground pins 3 and 6 necessary on the OBD connection, for UDS session ?


Sincerely






Pin assignment D-Sub


Pin Pin assignment
1 Not connected / optional +5V
2 CAN-L
3 GND
4 Not connected
5 Not connected
6 GND
7 CAN-H
8 Not connected
9 Not connected / optional +5V

User avatar
U.Wilhelm
Sales & Support
Sales & Support
Posts: 1198
Joined: Fri 10. Sep 2010, 19:34

Re: I can't establish a UDS session with a Digital Tachograp

Post by U.Wilhelm » Tue 7. Jan 2020, 08:25

Normally you only need CAN-H and CAN-L on a High Speed CAN (ISO 11898-2).
To be sure that the ommunication work, simply use the PCAN-View to check if the Basic Layer 2 Communication works before try to run a UDS High Layer Session.
--------------------------------
PEAK-System Technik
Technical Support Team
support@peak-system.com
-------------------------------

Post Reply